Back to overview
Resolved

CYC / CYG Server Maintenance

Sep 19, 2026 at 12:52pm UTC  –  Sep 19, 2026 at 1:16pm UTC
Affected services
CYC / CYG Website
CYC / CYG Dashboard

Resolved
Sep 19, 2026 at 1:16pm UTC

Maintenance ended

Created
Sep 19, 2026 at 12:52pm UTC

NOTE: This was cancelled due to a problem that encountered after the update.

The CYC / CYG Website & Dashboard will undergo maintenance to prepare for upcoming improvements and updates. During this period of time, the website and dashboard may be temporarily unavailable or experience brief interruptions.